Viewer Performance

Follow

Comments

48 comments

  • Avatar
    rabibori

    My model​ (https://skfb.ly/EwuI) looks distorted in the viewer. Please see the annotation.

  • Avatar
    kaadesign

    I always colouring the models BEFORE upload to sketchfab --> https://skfb.ly/ExoN

    STL-files can´t be coloured,- You must use a file format which is able to include color information. I.e DAE / Obj or blend.
    In this case I just loaded the file into "Blender", coloured the part and used the already integrated sketchfab uploader

  • Avatar
    rabibori

    Thank you, it's a good workaround to know. Makes it less convenient for someone to download and print the model.
    Is there a way to upload two files for the same model: one for rendering and another for downloading?

  • Avatar
    kaadesign

    I.e obj-files contain 2 files. You can zip this 2 files and upload to sketchfab after.
    If somebody downloads from Sketchfab, he´ll get the zip file with the 2 files again.

    Downloadable example: https://skfb.ly/ExIs

    if it is important to convert to stl , You can use the easy to use freeware "netfabb basic" to convert from obj to stl.

  • Avatar
    James

    Looks like there might be some weird stuff going on with normals, too, which causes unexpected shading: http://puu.sh/hUIs0/1dc02420cb.png

    Not much you can do about that, especially for STL, which contains no normal data and we smooth with default settings. Every software has different features (and worst of all, uses different words to describe them). But I can, for example, use "completely unwelded vertices" in Rhino, and export as OBJ: https://skfb.ly/ExKE

    Note the difference in vertex normals: http://puu.sh/hUJ8R/7ab936f2bd.png

    In that model, you avoid the weird shading, but don't get the nice smoothing on the curved parts (you can see every polygon). Ideally, I could go through and unweld only the edges that are causing problems.

  • Avatar
    rabibori

    Over-aggressive smoothing is a promising hypothesis. If someone is going to be fine tuning "the default settings", I can supply more examples. In fact, every model that I uploaded last night came across grotesquely distorted. A few weeks ago I uploaded a very similar model and don't remember there being a problem with rendering. And Blender doesn't have a problem with the model.

  • Avatar
    James

    At some point we may allow users to recalculate normals in 3D Settings with a choice of crease angles. But no ETA on that yet. We've tweaked the smoothing quite a bit already, but it will never meet every possible need. The best option right now is to explicitly set your own normals/smoothing. That said, please do send me samples, we'd love to take a look.

  • Avatar
    rabibori

    Here're a few distorted models: https://skfb.ly/ExqP, https://skfb.ly/ExpM, https://skfb.ly/ExnC, https://skfb.ly/ExoR. Thanks!

  • Avatar
    images--j_l_b.

    James
    I have been utilizing Sketchup #8 for three years and now I utilize sketchup 2015. I have had no problem with the pgn files whatsoever in the past and now the company I sent my pgn.files to requires that I utilize sketchfab!? Why do I all of a sudden have to become familiar with manipulating the number of polygons, meshes, and textures! This only happens when a CEO has no experience with rendering so of course he would recommend a website that is not user friendly. Most of us do not have the opportunity to learn all the facets of this platform you're not dealing with a demographic that is only 35 years old! Not all of the users have the ability to become literate with an abstract method of achieving an accurate portrayal of our renderings! Since I was not given the option not to use this website Why are certain types of rendering software not compatible with this platform! My intention is to achieve a cohesive and coherent rendering without the well's and but's hassle that are associated with this website!.

  • Avatar
    James

    @images--j_l_b.
    I'm not really sure what you're asking here. 3D assets should be shared in 3D, not 2D. We do our best to support all kinds of 3D software, including SketchUp. Thousands of users have SketchUp models successfully rendered on Sketchfab, and I'm happy to help you do the same. I will follow up via email.

  • Avatar
    stroporez79

    В каком формате нужно сохранить модель что бы к вам загрузить с текстурами ?

  • Avatar
    James

    @stroporez79 Lots of formats support textures: FBX, OBJ, DAE...

    Details here: https://help.sketchfab.com/hc/en-us/sections/200485707-Uploading-3D-Models

  • Avatar
    zulubo

    I have a problem that is not addressed. I uploaded my model and it completely uploaded and it switched to processing. It has been more than an hour now, the model only has 700 tris, and it says "pending" on my uploads page. I have tried a few other models as well, with the same result. Are the servers down or something? :(

  • Avatar
    James

    @zulubo Very sorry about that. We had some issues with our processing servers over the weekend. Things should be back to normal now.

  • Avatar
    exeshe4ki

    Hi! Really strange behavior i have with sketchfab. I've uploaded model with diffuse map. Share it via share button. Use link.
    If i watch my model with Xperia Z tablet in Chrome or Firefox browser it doesn't shows diffuse map, black colored model instead in HD mode. In LD is fine. Diffuse texture size is 4096 square.
    If i do the same things on my personal computer under Windows 7 everything works fine.
    Could it be some RAM limits problem on tablet or else?

  • Avatar
    James

    @exeshe4ki - If you're seeing a black model instead of the diffuse texture, yes, it usually indicates a lack of memory. Sometimes simply refreshing the page, switching HD → SD → HD, and/or reducing memory usage from other tabs/apps does the trick. This tablet probably does have the memory to render that texture, it may just have hiccuped.

  • Avatar
    BeakBlack

    My holographic model doesn't look like the same between 3D settings and the finished one!

  • Avatar
    James

    @BeakBlack - They look the same to me, can you elaborate and/or share some screenshots of the issue?

Please sign in to leave a comment.