Uploading 3D Models

Follow

Comments

130 comments

  • Avatar
    Perry82 (Sketchfab Profile)

    I tried it, but it is not possible, it has 420MB. If you have any advice, please. I deleted the texture.

    0
    Comment actions Permalink
  • Avatar
    stroporez79 (Sketchfab Profile)

    Почему нельзя загрузить просто файл (мах ) ? Неделю не могу ни чего найти что бы формат поменять на другой , и закинуть сюда свою работу.

    0
    Comment actions Permalink
  • Avatar
    Perry82 (Sketchfab Profile)

    Blender 2.78c :-)

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Those are both fairly complex, especially the number of textures. Could you try a really simple model such as this one to make sure it's not just the phone? https://sketchfab.com/models/442c548d94744641ba279ae94b5f45ec

    0
    Comment actions Permalink
  • Avatar
    hevakph (Sketchfab Profile)

    I have a problem with my Blender upload. The ceiling bricks are stretched.

    how to fix it?

    you can Download Here

     

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Perry82 (Sketchfab Profile)

    Trying to zip, I'll see. I'll let you know.

     

    0
    Comment actions Permalink
  • Avatar
    streetlightgraphics (Sketchfab Profile)

    I have made several attempts to upload a 3Ds model..when it comes in, there are pieces that have been shrunk down to tiny , almost invisible size and repositioned in the model. any ideas?

    0
    Comment actions Permalink
  • Avatar
    isbadan (Sketchfab Profile)

    Not sure if this would help your investigation but I noticed in Blender that if I have User Preferences not set to 'Auto Run Python Scripts' that my model gets all distorted by the armature when I close/re-open the file. Wondering if same thing happens to my uploads because my model looks squashed in a similar way. Python scripts are required for Rigify to work.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @felixcky if you include an empty file named "sketchfab.zbrush" in with all your OBJs/MTLs/textures, we will combine them all into a single model.

    0
    Comment actions Permalink
  • Avatar
    catlover0212 (Sketchfab Profile)

    so we have to download exportor to have an modle

    0
    Comment actions Permalink
  • Avatar
    isbadan (Sketchfab Profile)

    I'm trying to upload a character model using the Blender to Sketchfab exporter. Upload is only 7.4Mb. The character was rigged with Blender's Rigify armature and has about 8 seconds of animation. I added bones to the Rigify armature to animate a cape and a tail (character is a cat). Model loads and animates perfectly in Unity and looks really good in game. For some reason, the model displays in Sketchfab with missing limbs (arms, legs). Only the torso, head and tail show up. The body is a single object so its weird only parts of it are missing. The animation seems to go on but without arms to hold the sword. I don't want to apply the armature modifier because I don't want to freeze my model in a pose. The whole idea is to show the animation. Any recommendations on how to fix this problem?

    0
    Comment actions Permalink
  • Avatar
    hugoboss (Sketchfab Profile)

    I'm trying to run sketchfab on Maya 2015 but every time I click on the exporter icon in the CUSTOM tray, Maya just crashes over n over, attempting to save to the typical temp folder @ crash time. Is there something I did wrong? I ran the installer per the instructions, I just can't get to the part of entering my API code.

    0
    Comment actions Permalink
  • Avatar
    stereoaddress (Sketchfab Profile)

    And on what indicators should you pay attention when downloading the model, so that it works optimally on the phones?


    Is it possible to determine and say that one of these models will be much (and how much) optimized for phones
    1) https://skfb.ly/6t68I
    2) https://skfb.ly/6vxGV

     

    0
    Comment actions Permalink
  • Avatar
    adiks (Sketchfab Profile)

    Hi @James ! I've just uploaded a model of a Chinese oracle bone: https://sketchfab.com/models/96f9ae59a49b4a70a0c9b961602efcab 
    For some reason, the initial view showed the bone as tiny (I zoomed in and saved view so it looks bigger). This makes it hard to rotate the model easily. Not sure if the problem is in the original model - scale, or bounding box alignment? I couldn't locate the problem. Perhaps you could have a look?

    0
    Comment actions Permalink
  • Avatar
    isbadan (Sketchfab Profile)

    and also weird is the beauty shot in the preview window shows him intact in rest/T-pose which suggests to me the whole model including all textures were uploaded but the animation display view still has hidden portions and several textures are missing.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Hello @interbrandretail

    I only see one model on your account, and it appears to be working. Are you still having trouble?

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    There is no permanent list. It completely depends too much on the specific model.

    0
    Comment actions Permalink
  • Avatar
    mikefilmguy (Sketchfab Profile)

    Hello sketchfab help - had no problem at all uploading my first model via the built-in uploader in Agisoft Photoscan. I want to share this model with someone, but I also want to work on it more. Is it possible to send them the link and re-upload the model and have that same link work ? Or is a new link created everytime a model is uploaded or re-uploaded ? In Vimeo, I can replace the video file but the video link stays the same. Can't seem to find it in the knowledge database. Thanks ! Michael

    0
    Comment actions Permalink
  • Avatar
    amit3d (Sketchfab Profile)

    Hi here is the link

    https://www.dropbox.com/s/kd4juzumu28zcyr/Sample%20Test.zip?dl=0

    Its been uploaded through agisoft photoscan. Upload through sketchfab website failed several times.

    0
    Comment actions Permalink
  • Avatar
    hugoboss (Sketchfab Profile)

    Hey James,
    I am running the newest version directly from this site. I even tried reinstalling it from scratch but top no avail. My system is Windows 8.1 Pro 64bit with 12GB of RAM, AMD FX 4100 Quad Core, 3.62 GHz, and an Nvidia GeForce GT 640 card on a 48 inch flat screen. As for the Maya console, it doesn't give any errors i can see at the moment i click on it, then again i can't scroll through it after clicking the icon since i automatically get the crash dialogue blocking interaction with everything. from what I can see on the screen though it just looks like it runs a check of sorts on plugins perhaps, i'm not sure. Perhaps this may help...by default Maya loads up with all plugins loaded. I was thinking maybe something there may be conflicting with it. I also did do as per the instructions and set the settings on the export options menu verbatim. I did send off the crash report but I've never received any reply from autodesk after sending any reports to them in the past either. so I'm not holding my breath with them on this. Any clues? any other data/info I can provide to help?

    0
    Comment actions Permalink
  • Avatar
    frekky12 (Sketchfab Profile)

    @James - Thanks for your comment! I've been in contact with Klaasnienhuis to help resolve the issue on this post: http://forum.sketchfab.com/t/updated-3ds-max-to-sketchfab-exporter-sketchfab-blog/346/4

    I did what you suggested and exported an OBJ with a material library compressed into .7z format and the file size got shrunk down to 156MB so I'm going to have to wait to get a Sketchfab Pro account before it can be tested.

    I've also managed to successfully upload an FBX without textures and have only just worked out how to upload materials in the material editor. I didn't think it would be possible as the light bake unwrapped all of the textures and made it one material which is what I thought the FBX upload would be like too. The only problem with adding the textures this way is that I'm going to have to name every single material in the scene as well as converting all of my psd files to jpegs which is certainly a workaround. It would be good if one could automatically upload all textures in the material editor once uploaded!

    Thanks again!

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @adiks - Hi Adi!

    I'm not exactly sure what the issue was on that model, but we do have some bounding-box bugs on our end (fix coming in the next release).

    I improved the navigation for you by adjusting the up axis and moving it into a better position. How is it for you now?

     

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @JSRM Have you tried the 3ds Max Exporter plugin? https://sketchfab.com/exporters/3dsmax

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    I got it to work by exporting OBJ from blender. I will send the link to the email thread.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @schframe - I think you need to place the whole "Sketchfab-C4D-Exporter" folder, including the "res" folder with poster zip in the plugin directory.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Thanks! I made him private so your profile won't show a broken model. We're investigating!

    0
    Comment actions Permalink
  • Avatar
    stereoaddress (Sketchfab Profile)

    Good afternoon! and is there any list of phones on which there will be no problems with the reproduction of models?
    Or what is the ratio of the characteristics of the model and the characteristics of the phone?

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @mezzobed - What software are you using? I don't think materials are supported in IGES files.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @skarn - Great! Happy to help :)

    0
    Comment actions Permalink

Please sign in to leave a comment.