Compatibility

    WebGL

    To display 3D content in real-time we use WebGL, which is a standard in most modern browsers.

    You can check if your browser is compatible on http://get.webgl.org/

    For more technical details about WebGL on your machine, see http://webglreport.com/

    Desktop

    • Mozilla Firefox
    • Google Chrome
    • Opera
    • Safari (must enable manually in 7.1.3 [OS X 10.9] and earlier)
      • Go to Safari → Preferences → Advanced and check Show Develop menu in menu bar.
      • Go to Develop → Enable WebGL.
    • Internet Explorer, 11+

    Mobile

    • Android 4.0 with Firefox beta and Google Chrome
    • iOS 8
    • Blackberry browser

    Troubleshooting

    On older browsers or devices with WebGL disabled, models are displayed with an image-based fallback that gives a 360° turntable view of the model.

    If you run into problems, make sure your graphics driver and browser are up-to-date. If that doesn’t help, try one of the other browsers listed above. http://get.webgl.org/ is a good place to start troubleshooting.

    Sometimes, your browser may disable WebGL based on your GPU. If you are using a compatible browser, but you see an incompatible warning or the viewer performs very badly, try forcing the browser to use your GPU:

    Safari Cookies

    Safari's default handling of cookies from iframes can have undesirable effects on embedded models. If you experience issues entering a private model's password, liking a model, or downloading a model from inside an embed, check your Safari preferences:

    Safari cookie settings

    Have more questions? Submit a request

    Comments

    • Avatar
      James
      @Dmytro_Kovkun - Thanks! Do you mind installing Chrome to see if it's a Firefox issue? I have seen problems in the past with WebGL + FF + Ubuntu.
    • Avatar
      Dmytro_Kovkun
      @ James The same output in Chrome, so is it some OS issue?
    • Avatar
      James
      @Dmytro_Kovkun - Yes it could be an OS issue. I'm afraid I don't have a machine to test with myself. I'll ask our team.
    • Avatar
      Dmytro_Kovkun
      Thanks a lot for response. You do a great job.
    • Avatar
      Dmytro_Kovkun
      @James IT works if you run a chromium with this command : chromium-browser --ignore-gpu-blacklist Somebody knows the same command for firefox?
    • Avatar
      James
      Nice, I had forgotten about that flag in Chrome. Maybe this will help on FF? http://www.sitepoint.com/firefox-enable-webgl-blacklisted-graphics-card/
    • Avatar
      Dmytro_Kovkun
      Just want to report than my FireFox updated to 44.0 and WebGL now works fine, so it was a FF issue. Maybe this information will be usefull somehow for somebody
    • Avatar
      James
      Great! Thanks!
    • Avatar
      boispe

      Hi, nothing happens on my samsung tab 4. OS android 4.4.2. Tried with up to date Opera, Opera beta, Firefox, Firefox beta, Safari, Chrome, Chrome beta.
      I tried http://get.webgl.org on each. It works perfectly. I can see the cube…
      But nothing happens with my Sketchfab models…
      Did I miss something please ?
      Thanks for your answer
      Chris

    • Avatar
      James

      @boispe Hi Chris,

      You say 'nothing happens' - do you see the WebGL Fallback warning that links to this page? Or you don't see anything at all?

    • Avatar
      boispe

      In fact, I see the environment, a grey background but no object, no message, no arrow… I could send you a sreenshot to show you…

    • Avatar
      James

      Yes, please do! Can you email me with screenshot and any other info? support@sketchfab.com

    • Avatar
      sarapixelpixie

      I had a problem on my Macbook using chrome, I found this link which helped me fix it right away

      http://superuser.com/questions/836832/how-can-i-enable-webgl-in-my-browser

      Hope it helps

    • Avatar
      broadleaf

      im using firefox and i have gtx980 and i cant view my own models, fix it.

    • Avatar
      broadleaf

      It was working fine, why you have to break things? Just leave it as it was now i cant show the models to client, great job.

    • Avatar
      James

      @broadleaf - I'm sorry about that. You can't view any of your own models? What do you see when you try? Are there any errors in the browser console when the page/model is loading?

      Are you able to view the models on this page? https://help.sketchfab.com/hc/en-us/articles/204149909-Debug-Resources

    • Avatar
      terentiy

      Cannot see any model in safari! Tried on two different computers! no problem with chrome and firefox, just safari stopped working a day ago! 

      -Allow WebGl is checked in preferences.

      -There is no "Enable WebGl" in a develop tab

      -Using safari 9.1.1

    • Avatar
      terentiy

      The blue status bar on the top runs up to i think 98% and stops. Also, i can see cubes here: https://help.sketchfab.com/hc/en-us/articles/204149909-Debug-Resources

      But other model no.

    • Avatar
      terentiy

      Now this is very strange: i can view some models. I can view every other model here http://www.iamag.co/features/sketchfab-realtime-selection-66/

      Some model loads up but some don't

    • Avatar
      luis888

      Hi, exactly same problem than terentiy here, blue status bar stops after 98% with some models incuding mine, Only in Mac OSX Safari (Chrome, Firefox, IOS Safari are OK, Mac osx safari webgl test OK)

      Imac 2009  iMac11,1 - Chipset Model: ATI Radeon HD 4850/512 MB - OS X 10.11.5 (15F34) -Safari Version 9.1.1 (11601.6.17)

      Best regards

       

       

    • Avatar
      luis888

      Hi, tried debug http

      DOES NOT HANGS AT 98% EVERYTHING OK WITH pbr lit + light + postprocess  (or before)

      DOES HANGS AT 98% WITH classic lit + environment + postprocess and all following tests, seems that environment is responsible of the fault.

      The only difference in Safari logs is the following error message that does not appear when it is working OK.

      [Error] RangeError: Length out of range of buffer nrWrapper (embed:6:11159)

      Safari LOG when clicking play:

      [Debug] osgjs.metric:ReaderParser.parseSceneGraph: 2.821ms
      [Error] RangeError: Length out of range of buffer nrWrapper (embed:6:11159)
      [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (20-b9cfcfb4e1e381427d07.js.map, line 0)
      [Warning] Using fallback Android device measurements. (20-b9cfcfb4e1e381427d07.js, line 73)

      IT STOPS HERE BEFORE THE DOWNLOAD LOG print

      Hope this helps

      Regards

       

       

       

    • Avatar
      James

      @terentiy @luis888

      Thanks for the reports. It's related to Environment lighting. We have a fix coming ASAP.

    • Avatar
      luis888

      OK thank'you, I cannot save from SF 3D editor (as it crashes before loading), but some other models are OK, whet do I have to modify in my Blender model to be able to upload a new model than will work with SF

       

    • Avatar
      luis888

      SUPERB NEW VIEWER, FASTER, SHINE WITH SAFARI TOO WITH MY MODEL.

      Congratulation for the development team, not only it corrected problems but it gives us a new superb viewer, faster and lots of new possibilies.

      Regards

       

    • Avatar
      Peekofwar

      On a Sony PlayStation 4 I get the image only view. Does the P.S.4 browser not support OpenGL?

    • Avatar
      James

      @Peekofwar - Yes, it looks like there is no support for WebGL on the PS4.

    • Avatar
      Peekofwar

      @James I would get a third-party web browser but there aren't any and I don't think I can... [

    • Avatar
      James

      @Peekofwar - Yeah, I'm not sure if there is a solution at the moment :\

    • Avatar
      AlexVuks

      Can't see transparency, and problems with reflections on iphone 5 ios 9, any ideas?

      Thanks Alex

    • Avatar
      James

      @AlexVuks - Hi Alex. I'm sorry you're having trouble. Could you give me some specific model examples?

      By the way, shadows don't work on iOS, so if you're viewing a model whose lighting heavily relies on shadows, it probably won't look great on iOS.