Re-uploading a Model

Follow

Comments

48 comments

  • Avatar
    James (Sketchfab Profile)

    Hi,

    It's not an exact science, but we try to preserve any settings you've made in the editor if your new version does not over override them. Do you have a specific example where this is not working so we can take a closer look?

    0
    Comment actions Permalink
  • Avatar
    julzdesigns (Sketchfab Profile)

    Is it possible to do a reupload when using the 3DS Max Sketchfab Exporter/ Plugin? Everytime I've used it so far you have to create a new model.

    1
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @julzdesigns - Not at the moment, but we would very much like to implement that feature in our plugins in the future. For now, you could manually export and re-upload the model, or use the plug-in, download the new version from Sketchfab, and re-upload it over the original.

    1
    Comment actions Permalink
  • Avatar
    SubmarineChannel (Sketchfab Profile)

    My audio has disappeared after re-uploading. Shouldn't that be preserved as well?

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @SubmarineChannel Sorry about that! We're working on a fix.

    0
    Comment actions Permalink
  • Avatar
    jlottrenderinghouse (Sketchfab Profile)

    Hello! I was wondering why after I optimized my textures for my model, after reuploading to the same scene the model information does not update? Specifically the size and poly count? 

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Hi there! Hmm that sounds weird, can you share the model link so we can take a look?

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    I reproduced the model size problem (we'll ge that fixed), but my poly count was updated correctly :\

    0
    Comment actions Permalink
  • Avatar
    jlottrenderinghouse (Sketchfab Profile)

    @james 
    After clearing the cache and reuploading for an additional time, I was able to have the poly count updated again! Though looking forward when you get the model size problem fixed. Thanks for your input!

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @jlottrenderinghouse Cool, thanks for letting me know!

    0
    Comment actions Permalink
  • Avatar
    filibis (Sketchfab Profile)

    Hi @james , is there any progress about the re-upload feature via plugins (Blender for example)? (Same question asked by @julzdesigns a year ago)

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Hi @filibis - At the moment, I think Substance Painter is the only software to implement re-upload in the exporter/plugin.

    1
    Comment actions Permalink
  • Avatar
    edwin.wallet (Sketchfab Profile)

    Is "staffpick" preserved when you re-upload?

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @edwin.wallet Yes it is. I just updated the list in this article, thanks!

    0
    Comment actions Permalink
  • Avatar
    Theon (Sketchfab Profile)

    I almost always have to re-apply most, if not all of my textures and material settings when I re-upload. This very frustrating. I have like 9 materials which I've spent hours adjusting, and then I find a tiny weight painting error, and if I fix that error and reupload everything without any additional changes, it all breaks and I have to start over with the materials from scratch. Is it supposed to be this way, or am I doing something wrong?
    Also, is it possible to only re-upload the mesh, and not all the unchanged textures? I've tried before, but all my textures were simply removed if I didn't include them in the second upload.

    Thank you for your time

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    @Theon

    All your material/texture settings should be preserved between uploading, even if you only re-upload the mesh, as long as your material names don't change.

    Can you send me the latest model URL where this happened?

    0
    Comment actions Permalink
  • Avatar
    Theon (Sketchfab Profile)

    Hi, James,

    Thanks for the quick reply!

    It's been a long time since I tried re-uploading only the mesh, so I'm not sure which one that was. As for materials resetting when I re-upload everything (including the textures), that happens almost every time. I can't remember last time I uploaded a model that I didn't have to redo the materials for, because I always end up having to re-upload it.

    Last this happened was with this one:

    https://skfb.ly/6NWGM

    Even the post processing and light settings disappeared at one point.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Thanks Theon! We're taking a look.

    0
    Comment actions Permalink

Please sign in to leave a comment.