Desktop WebVR (Vive, Oculus)

Follow

Comments

104 comments

  • Avatar
    core10arch

    Error 404 when I try this

    0
    Comment actions Permalink
  • Avatar
    James

    @core10arch - the embed parameter or WebVR?

    0
    Comment actions Permalink
  • Avatar
    blueties

    i get the same error as #core10arch.... I added /embed?cardboard=1 to the URL, but it won't load my model:(

    0
    Comment actions Permalink
  • Avatar
    James

    @blueties - Looks like you only have a model in Draft mode on your account. You need to Publish it before you can use the embed features.

    0
    Comment actions Permalink
  • Avatar
    barentsenma87

    I believe I've published my model, but still wont load, and sometimes get the 404 error..

    0
    Comment actions Permalink
  • Avatar
    James

    @barentsenma87 - The Helicopter model? It works fine for me. Does it happen all the time? Or just on a specific device or VR mode?

    0
    Comment actions Permalink
  • Avatar
    barentsenma87

    Jeah, Think its a device thing. Adding the /embed?etc on my desktop does show the stereoscopic view but on my phone (s5 mini) it doesn't not in chrome nor on the device's default browser..

    0
    Comment actions Permalink
  • Avatar
    James

    I tested a physical S5 and an emulated S5 Mini (via BrowserStack). The stereoscopic mode worked on the S5 but WebGL was disabled on the S5 Mini emulator, so I couldn't test any further. Do models in "regular" mode work for you?

    0
    Comment actions Permalink
  • Avatar
    barentsenma87

    @James, Yes I tested the model om various physical devices. The s4 (GT-I9500) Works fine with VR, so does the Iphone 4. The s5 mini (SM-G800F) and the Huawei P6 both have problems with VR. All phones do however show the regular model.

    0
    Comment actions Permalink
  • Avatar
    James

    Hmm ok. Yes it does sound like a device limitation. I'll do some digging and let you know if I find anything.

    0
    Comment actions Permalink
  • Avatar
    julian_becker
    Did you find any solution? I'm having the same problem ..
    0
    Comment actions Permalink
  • Avatar
    James
    @julian_becker - Not yet, we're having trouble pinning down the cause (device-specific? android version-specific?) What device and OS version are you on?
    0
    Comment actions Permalink
  • Avatar
    julian_becker
    I'm on a huawei p8 running android 5.0.1 .. gonna try my old galaxy s II too and leave a comment
    0
    Comment actions Permalink
  • Avatar
    barentsenma87
    Hy guys, to add to the info. The Huawei P6 I tested was on Android 4.3. The S5 Mini was on Android 4.4.2 I tought it would be memory related. But if Julian's running A P8 with Lollipop that doesn't seem to be the issue..
    0
    Comment actions Permalink
  • Avatar
    barentsenma87
    Could it be the Wifi 802.11 AC? This faster wifi type is not on the P6, P8 and S5 mini. It is however already on the older Galaxy s4
    0
    Comment actions Permalink
  • Avatar
    James
    Interesting. If anyone/everyone can share debug info like console output and http://webglreport.com/ reports for devices, it could help.
    0
    Comment actions Permalink
  • Avatar
    James
    Not sure why Wifi would make a difference, once the model is loaded into memory there are no more requests.
    0
    Comment actions Permalink
  • Avatar
    julian_becker
    i guess i got the solution thanks to an automated mail by yours. My model has only been uploaded which did not allow me to use the cardboard function. now i got a mail which remembered me to also publish the uploaded model and see .. cardboard-view is working fine!
    0
    Comment actions Permalink
  • Avatar
    James
    Ah of course, models have to be published to access /embed.
    0
    Comment actions Permalink
  • Avatar
    3dscann
    The tutorial says "Insert your smartphone in a Google Cardboard or a similar smartphone based headset (e.g Samsung Gear VR)Insert your smartphone in a Google Cardboard or a similar smartphone based headset (e.g Samsung Gear VR)" As far as I know there is no way of accesing the Samsung Gear VR outside of the Oculus store? Am I missing something here, because the first thing that happens when you insert the phone into the Gear VR headset is that the native app opens, hence you no longer see the Sketchfab VR.
    0
    Comment actions Permalink
  • Avatar
    James
    @3dscann - You're right! Sorry for the confusion - I removed it from the tutorial. We will need to create a native app for the Gear VR for it to work.
    0
    Comment actions Permalink
  • Avatar
    pneuhaus

    Hi, I am having trouble looking at my model with a DK2. I published it and it works fine for an iphone with cardboard. When I try to view it on Nightly with my DK2 it recognizes the DK2 and the light turns on, but the image is black once I get past the warning screen. Do you know what could be going wrong?

    0
    Comment actions Permalink
  • Avatar
    pneuhaus

    I'll add that I tried both the Virtual Reality view mode and the embed link with the same result.

    0
    Comment actions Permalink
  • Avatar
    James

    Hi @pneuhaus - The Oculus stuff is pretty experimental and buggy right now, but we're working to fix it and make it more reliable as soon as possible.

    0
    Comment actions Permalink
  • Avatar
    dskeith

    Hi - I'm attempting to view various SketchFab models on my mobile phone (Moto X w/ Lollipop in Chrome) but the website is stuck in Portrait orientation. Even when I hold my phone in Landscape, and go into Full-screen I get a Portrait VR experience which won't work w/ my Google Cardboard. Any recommendations?

    Thanks!

    0
    Comment actions Permalink
  • Avatar
    James

    @dskeith - Strange. Are you able to load regular pages (like the model page) in landscape? Can you try going into landscape first, then going to the VR mode?

    0
    Comment actions Permalink
  • Avatar
    dskeith

    @James - User error, I had "Portrait Lock" on for my phone, I accidentally set that when adjusting my screen brightness settings. I have run into a few other issues though:

    1. Switching to VR mode will very often move my camera to a completely different location, using Set/Save View for Orbit or First Person doesn't seem to work.
    2. VR Mode still accepts finger input, which means that my camera will move as a result of putting it into my Google Cardboard.
    3. Sometimes the VR head movement shifts from a FPS style movement, to a very disconcerting orbit-style movement.
    4. "Front" seems to be locked as opposed to being set when I switch to VR mode, which means I sometimes have to spin 180 degrees to get back the viewpoint I had when I made the switch. (Possibly related to #1)

    The prospect of < 1min from my content creation app to a web-based VR viewer on my phone is amazing, but it doesn't seem like that's a reality just yet. Or - hopefully - this is even more user error on my part!

    0
    Comment actions Permalink
  • Avatar
    James

    @dskeith - Thanks!

    We're rapidly iterating on VR navigation and behavior. We know there are a lot of issues and we will improve everything over time.

    0
    Comment actions Permalink
  • Avatar
    Caroline Erolin

    Hi, I was wondering if you've had any luck in creating a native app for the Gear VR yet?  Thanks!

    0
    Comment actions Permalink
  • Avatar
    James

    @cderolin - Not yet, but it's on our roadmap!

    0
    Comment actions Permalink

Please sign in to leave a comment.