Desktop WebVR (Vive, Oculus)

Follow

Comments

93 comments

  • Avatar
    barentsenma87
    Hy guys, to add to the info. The Huawei P6 I tested was on Android 4.3. The S5 Mini was on Android 4.4.2 I tought it would be memory related. But if Julian's running A P8 with Lollipop that doesn't seem to be the issue..
  • Avatar
    James

    @geogan Hmm ok. What version of Firefox and Windows?

  • Avatar
    James

    @mantasT - WebVR is supposed to be coming to the stable version of Chrome very soon, but I can't say for sure :\

  • Avatar
    joprog

    Note 5, Gear VR. Model loads but no navigation, so can only look at one static view of my model. Look forward to your next release. thanks

  • Avatar
    geogan

    @mantasT Did you do remember to turn on the functionality in Chromium with chrome://flags/#enable-webvr as I said above? The other browsers didn't work for me in Windows 7 but Chromium does last time I checked.

  • Avatar
    pneuhaus

    I'll add that I tried both the Virtual Reality view mode and the embed link with the same result.

  • Avatar
    geogan

    And I can't get VR to open at all in the latest Chrome I have (61.02163.91). Just throws up those two information boxes on model display about "get a VR-compatible browser"... and I even went into the settings and turned on the VR option with chrome://flags/#enable-webvr

    Maybe your whole VR system is just not compatible with Windows 7 at all. Does Oculus work for *anyone* with this system in Windows 7?

  • Avatar
    brui

    Hi @James, I just got the Cardboard V2, works great!

  • Avatar
    julian_becker
    i guess i got the solution thanks to an automated mail by yours. My model has only been uploaded which did not allow me to use the cardboard function. now i got a mail which remembered me to also publish the uploaded model and see .. cardboard-view is working fine!
  • Avatar
    brui

    I see, thanks! For the moment I was able to make it work with this hack, I will have to get the V2 or a plastic visor one that have the same function, I will look around

    https://www.youtube.com/watch?v=7Na7HsX_N-o&list=RD1UA7I8uuA9M&index=2

  • Avatar
    barentsenma87
    Could it be the Wifi 802.11 AC? This faster wifi type is not on the P6, P8 and S5 mini. It is however already on the older Galaxy s4
  • Avatar
    miguelangelo2k

    @James

    I have had feedback from several people who tried to get my animations into the vive via web VR ...i had the chance to try it the other day at a friends place...he is a crack in visuals and with all the programs...

    but we could not get it right ...we had steamVR and webVr for chromium installed and everything set...but clicking the VR button in the modelviewer just shows the url to be entered in the mobile...

    we tried everything and could not get it...the sketchfab app from steam works fine...and sends nothing to the vive...

    do you have any tip for us...what could it be we all are doing wrong ?

     

     

  • Avatar
    dskeith

    I'm loving the new Cardboard app, really great framerates compared to the WebGL mobile player. Any sense of when we'll be able to push our own content to these apps?

  • Avatar
    dazirius

    And now it's working :D Grand!

  • Avatar
    mantasT

    @geogan thanks for your concern. I tried scanning this chrome version but no threats detected.. and it is still the only browser that shows me skechfab in oculus rift (in firefox i hit vr button and in rift i see oculus home fade to black and then it fades back to oculus home.. no model from skechfab from firefox ..) 

  • Avatar
    blueties

    i get the same error as #core10arch.... I added /embed?cardboard=1 to the URL, but it won't load my model:(

  • Avatar
    julian_becker
    I'm on a huawei p8 running android 5.0.1 .. gonna try my old galaxy s II too and leave a comment
  • Avatar
    James

    @mantasT - You can always get the latest version here: https://webvr.info/get-chrome/ (v1.1, 23 December )

  • Avatar
    dazirius

    Ah ha! @James, that's great news!

    Cheers!

  • Avatar
    geogan

    OK... "Chromium" - the experimental open source version of Chrome.... appears to be working... I still had to do the chrome://flags/#enable-webvr first... but now the models open up in Oculus and is stable... not crashing and good framerate... not juddery like the one or two times it opened in Firefox.

  • Avatar
    James
    Interesting. If anyone/everyone can share debug info like console output and http://webglreport.com/ reports for devices, it could help.
  • Avatar
    James

    @cderolin - Not yet, but it's on our roadmap!

  • Avatar
    barentsenma87

    Jeah, Think its a device thing. Adding the /embed?etc on my desktop does show the stereoscopic view but on my phone (s5 mini) it doesn't not in chrome nor on the device's default browser..

  • Avatar
    direhawk

    I am a Rift user with Oculus Touch controllers, WebVR has never worked for me.   I would like to load up my sketchfab models into my HMD but it has never worked through the browser interface. (WebVr seems more tailored for smart phone VR)  The Sketchfab app in the Oculus store is great but it dosn't allow you to access your own models or collections.  When is Sketchfab going to release a complete Rift or Vive stand alone app to view all Sketchfab models uploaded by us creator's and not just there own collection.

  • Avatar
    James
    Not sure why Wifi would make a difference, once the model is loaded into memory there are no more requests.
  • Avatar
    James

    Hi @brui, The iOS app is designed to be used with a Google Cardboard, which has a button to click/tap the screen for you. The app is still young, and we'll improve things as we go.

  • Avatar
    James

    Hmm ok. Yes it does sound like a device limitation. I'll do some digging and let you know if I find anything.

  • Avatar
    James

    @dskeith - No  ETA at the moment, but the goal is for every Sketchfab model to be viewable in a VR app.

  • Avatar
    James

    Hmm that's not good! I'll try to reproduce it. Did you notice this on any model or just certain models?

  • Avatar
    James

    @core10arch - the embed parameter or WebVR?

Please sign in to leave a comment.