Understanding Error Codes

Follow

Comments

6 comments

  • Avatar
    andrescl94 (Sketchfab Profile)

    Hey James, I'm working on a script to upload several models to Sketchfab automatically, but I'm having an issue where the API returns an error message saying "The model is already being processed". All models uploaded are different devices and the files have different names.

    My question is, how do you guys check if a model is already being processed? Just by the name of the file? Or you check and compare hashes of the file, or model dimensions or something like that? Because some devices could be exactly the same and that would explain the error I'm getting.

    Thanks in advance.

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    Hey, good question. We use the MD5 hash of the uploaded file to check if the same file is already being processed.

    1
    Comment actions Permalink
  • Avatar
    Aligned-VR (Sketchfab Profile)

    I am getting error 404 page cannot be found when attempting to upload from Revit

    1
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    After the upload completes and you try to view the model? What is the URL? It looks like you have successful uploads: https://sketchfab.com/Aligned-VR/uploads

    0
    Comment actions Permalink
  • Avatar
    ATD-London (Sketchfab Profile)

    I am having the same issues as 'Aligned-VR' 

    The URL I am getting is this ...>>> https://sketchfab.com//uploads

    The text shown on the page is as follows....

    Error 404

    The page cannot be found
    Please check the address or go back to the homepage

    0
    Comment actions Permalink
  • Avatar
    James (Sketchfab Profile)

    It looks like the exporter might just be showing the same URL. You can find your uploads here: https://sketchfab.com/ATD-London/uploads

    0
    Comment actions Permalink

Please sign in to leave a comment.